InterMountain ESD - EAC Reimbursement Request Submission Issue – Incident details

All systems operational

EAC Reimbursement Request Submission Issue

Resolved
Partial outage
Started 5 months agoLasted 9 days

Affected

Operational

Partial outage from 5:17 PM to 2:30 PM

PowerSchool Employee Access Center (EAC)

Partial outage from 5:17 PM to 2:30 PM

Updates
  • Resolved
    Resolved

    The issue affecting reimbursement submissions has been resolved.  PowerSchool released a fix on July 19th, and the submission process is now working properly.

  • Monitoring
    Monitoring

    PowerSchool has confirmed that the fix for this issue will be included in the upcoming escalation release, which is scheduled for deployment no later than Saturday, July 19.

  • Identified
    Identified

    We are aware of an issue affecting the submission of reimbursement requests in which the screen refreshes without displaying an error message, but the reimbursement is not actually submitted. Staff are still able to save reimbursement forms as drafts.

    PowerSchool has identified the root cause of the problem, which stems from a code change introduced on July 4th. They are actively working on a resolution and anticipate releasing a fix on July 19th.

    Thank you for your patience as we work with PowerSchool to address this issue.