InterMountain ESD - Employee Access Center Error - Budget Unit Not Valid – Incident details

All systems operational

Employee Access Center Error - Budget Unit Not Valid

Resolved
Degraded performance
Started 3 months agoLasted 6 days

Affected

Operational

Degraded performance from 5:45 PM to 2:58 PM

PowerSchool Employee Access Center (EAC)

Degraded performance from 5:45 PM to 2:58 PM

Updates
  • Resolved
    Resolved

    PowerSchool released an update over the weekend resolving this issue.

  • Investigating
    Investigating

    We are currently aware of an issue in the Employee Access Center that is preventing users from entering budget codes on reimbursement forms. When attempting to submit, users receive an error indicating that the budget unit is not valid. We have reported the issue to PowerSchool and are awaiting their assessment.