InterMountain ESD - Google Service Outage Affecting Chromebook Sign-Ins – Incident details

All systems operational

Google Service Outage Affecting Chromebook Sign-Ins

Resolved
Major outage
Started 4 months agoLasted about 5 hours

Affected

Cloud Services

Operational from 2:30 PM to 7:03 PM

Google

Operational from 2:30 PM to 7:03 PM

Gmail

Operational from 2:30 PM to 7:03 PM

Google Classroom

Operational from 2:30 PM to 7:03 PM

Google Drive

Operational from 2:30 PM to 7:03 PM

Updates
  • Resolved
    Resolved

    This incident appears to be resolved. We will continue to monitor the situation and provide updates if there are any further interruptions.

  • Monitoring
    Monitoring

    Google has reported that the issue has been resolved. At this time, we are monitoring the situation and waiting for confirmation that Chromebook sign-ins are fully restored. We will provide another update once the resolution is verified.

  • Identified
    Identified
    We are currently experiencing a widespread issue where most users are unable to sign into Chromebooks due to a Google service outage. This disruption is preventing authentication at the login screen. Our team is actively monitoring Google’s status and will provide updates as more information becomes available.