InterMountain ESD - Azure Front Door - Connectivity issues – Incident details

All systems operational

Azure Front Door - Connectivity issues

Resolved
Degraded performance
Started 3 months agoLasted about 7 hours

Affected

Cloud Services

Degraded performance from 4:00 PM to 7:59 PM, Operational from 4:00 PM to 10:52 PM, Degraded performance from 7:59 PM to 10:52 PM

Microsoft

Degraded performance from 4:00 PM to 7:59 PM, Operational from 4:00 PM to 10:52 PM, Degraded performance from 7:59 PM to 10:52 PM

Microsoft Exchange/Outlook

Degraded performance from 4:00 PM to 10:52 PM

Microsoft SharePoint

Degraded performance from 4:00 PM to 10:52 PM

Microsoft OneDrive

Degraded performance from 4:00 PM to 10:52 PM

Microsoft Teams

Degraded performance from 4:00 PM to 10:52 PM

Updates
  • Resolved
    Resolved

    Microsoft has stated on their outage page that they are monitoring the recovery of this outage.

  • Monitoring
    Monitoring

    The login appears to be fixed. But Microsoft has still not marked the issue as fully resolved.

  • Identified
    Identified

    Starting at approximately 16:00 UTC, customers and Microsoft services that leverage Azure Front Door (AFD) may have experienced issues resulting in latencies, timeouts and errors. We have confirmed that an inadvertent configuration change as the trigger event for this issue.

    Customers may have experienced problems accessing the Azure management portal.