InterMountain ESD - Canva – Incident details

All systems operational

Canva

Resolved
Operational
Started 19 days agoLasted 4 days

Affected

Cloud Services

Major outage from 2:00 PM to 5:20 PM

Other Cloud Services

Major outage from 2:00 PM to 5:20 PM

Updates
  • Resolved
    Resolved

    All Canva access has been fully restored. An additional issue was identified during verification and has been resolved. End users have confirmed that all services are functioning normally. If anyone experiences further issues, please contact the Helpdesk for assistance.

  • Monitoring
    Monitoring

    The Canva SAML issue appears to be resolved. We are currently confirming functionality with end users to ensure access is fully restored. Another update will be provided once verification is complete.

  • Update
    Update

    Canva has not provided any response or progress update overnight regarding the SAML certificate fix. We are continuing to wait for their support team to complete the update on their end. Further information will be shared as soon as it becomes available.

  • Update
    Update

    Canva has confirmed our diagnosis of the SAML issue. Their team requested our updated certificate and it has been provided. They will be applying the update on their end, and access should be restored once their support completes that change. Further updates will be shared as we receive them.

  • Identified
    Identified

    The IMESD team has identified the issue with the vendor’s product affecting our Canva SAML integration. We have provided detailed findings to the vendor, but they have not yet responded. We are currently awaiting restored administrative access so we can complete recovery. Further updates will be posted as we receive them.

  • Investigating
    Investigating

    We are currently experiencing an issue with Canva single sign-on (SSO). Users attempting to log in with district accounts may receive an access error. We’re working with Canva to restore SSO functionality as quickly as possible.