InterMountain ESD - Clever – Incident details

All systems operational

Clever

Resolved
Major outage
Started about 1 month agoLasted about 2 hours

Affected

Cloud Services

Major outage from 8:54 PM to 11:02 PM

Other Cloud Services

Major outage from 8:54 PM to 11:02 PM

Updates
  • Resolved
    Resolved

    Incident resolved

    Amazon AWS has resolved this issue, all Clever functionality should be restored.

  • Identified
    Identified

    Identified - Amazon AWS, a service that works with Clever, is experiencing a issue that is preventing users from being able to log in to Clever. We are monitoring the issue and will provide status updates as they become available.

  • Investigating
    Investigating

    Clever is currently investigating an issue where clever.com/login is inaccessible. As soon as we have more information, we will provide an update.