InterMountain ESD - EAC Leave & Reimbursement Outage – Incident details

All systems operational

EAC Leave & Reimbursement Outage

Resolved
Partial outage
Started 6 months agoLasted about 23 hours

Affected

Operational

Operational from 4:37 PM to 3:44 PM

PowerSchool Employee Access Center (EAC)

Operational from 4:37 PM to 3:44 PM

Updates
  • Resolved
    Resolved

    The issues affecting leave and reimbursement submissions and workflow approvals in the EAC have been resolved. Access to the Leave Reporting and Reimbursement screen has been restored, and the system is functioning as expected.

  • Identified
    Identified

    We are currently experiencing issues with leave and reimbursement submissions, as well as workflow approvals, in the EAC. PowerSchool has been notified, and we are working with them to resolve the issue.

    In the meantime, the Leave Reporting and Reimbursement screen has been temporarily removed from the EAC to prevent further disruption.

    We will provide updates as more information becomes available. Thank you for your patience.