Scheduled for June 30, 2025 at 10:00 PM – July 03, 2025 at 12:00 AM
Affects
Operational
Under maintenance from 10:00 PM to 12:00 AM
PowerSchool Employee Access Center (EAC)
Under maintenance from 10:00 PM to 12:00 AM
Updates
Completed
July 03, 2025 at 12:00 AM
Completed
July 03, 2025 at 12:00 AM
Maintenance has completed successfully
In progress
June 30, 2025 at 10:00 PM
In progress
June 30, 2025 at 10:00 PM
Maintenance is now in progress
Planned
June 30, 2025 at 10:00 PM
Planned
June 30, 2025 at 10:00 PM
The Employee Access Center (EAC) will be temporarily unavailable due to scheduled upgrades to the Reimbursement and Leave workflow systems. During this time, staff will not be able to access the EAC.
We appreciate your patience and understanding as we work to improve our systems.