InterMountain ESD - IMESD - Inbound Phone Call Outage – Incident details

All systems operational

IMESD - Inbound Phone Call Outage

Resolved
Major outage
Started 4 months agoLasted 29 minutes

Affected

Infrastructure

Major outage from 9:04 PM to 9:33 PM

Phone System

Major outage from 9:04 PM to 9:33 PM

Updates
  • Resolved
    Resolved

    The issue affecting inbound phone calls has been resolved.  All inbound, internal, and six-digit district dialing are now fully operational.

    Thank you for your patience while we worked with our service provider to restore service.

  • Investigating
    Investigating
    We are currently experiencing an outage with our inbound phone lines due to a service provider issue. At this time, incoming calls from outside IMESD may not be received. Please note that internal dialing and six-digit district dialing remain operational. Our team is actively working with the provider to resolve the issue as quickly as possible. We will provide updates as more information becomes available.